RSS Feed
News
Jun
22
VPOP3 v7 upcoming & beta-testers wanted
Posted by Paul Smith on 22 June 2016 08:53 AM

The next version of VPOP3 that we are planning will be version 7. We are changing from the 6.x sequence because we are planning two relatively major changes:

  1. Change from PostgreSQL 9.1 to 9.5
  2. Release 64 bit version of VPOP3

People with active support/maintenance agreements at the time of its release will be able to upgrade to version 7 as part of that agreement.

We are anticipating release around late September 2016.

Change from PostgreSQL 9.1 to 9.5

PostgreSQL 9.1 is nearing end-of-life in September 2016. While we haven’t encountered any major problems with it, there are many improvements in later versions of PostgreSQL which will help performance and also make some things that VPOP3 does easier.

VPOP3 already runs on any version of PostgreSQL from 9.1 or later, but it is quite a major process to upgrade the major version of PostgreSQL. This is why we have not previously kept up with the latest versions of PostgreSQL in our standard installation process.

When going from VPOP3 v3/4 (which used PostgreSQL 8.3) to v5/6 (which uses 9.1) we had to backup & restore the full database which could take several hours for some users. This was required because the build method of the pre-built PostgreSQL binaries had changed between 8.3 and 9.1.

However, the build method of 9.5 is compatible with that of 9.1, so we can use a ‘shortcut’ method using a program called pg_upgrade. When we have tested it here, it takes just a few minutes to upgrade a 30GB v9.1 database to v9.5. It is slightly complex so we will be trying to automate it for you.

One of the ‘disadvantages’ of using pg_upgrade is that we cannot convert the database to work with a 64 bit version of PostgreSQL, so we will have to stick with a 32 bit version of PostgreSQL even for the 64 bit version of VPOP3. We don’t anticipate this being a problem. If you want to use a 64 bit version of PostgreSQL, that will work fine with VPOP3, but you will still have to do the full dump/restore process to migrate the database in that case. This won’t be part of the standard installation procvess.

Release 64 bit version of VPOP3

For a while we’ve been wanting to release a 64 bit version of VPOP3. Tests we’ve done show our 64 bit builds working fine. There are a few limitations with the 64 bit version we are working with so far:

  • it requires Windows 2008/Vista or later (not that big a problem since 64 bit versions of Windows XP were rare)
  • it doesn’t support the standalone fax plugin (but will support the PAYG fax service)
  • it doesn’t support WebMail spellchecking (we may look at trying to re-add this if there is enough interest)
  • it doesn’t support the VPOP3AV antivirus plugin. We will be working on this (we don’t anticipate any problems implementing this, it’s just a lack of time so far)

(The above are mostly not because of any problems with the 64 bit VPOP3, but because we use third party components for which we do not have 64 bit versions, so adding them will incur extra licensing costs for us).

The 64 bit version of VPOP3 should alleviate some problems we have encountered in a few cases.

The main one is that problems due to virtual address space fragmentation should be practically eliminated. This problem has caused issues when people have tried to have VPOP3 process very large emails (>100MB).

VPOP3 will also have access to more than 3GB of memory. This shouldn’t solve any existing problems by itself, but it does mean we can consider adding more in-memory caching for some data to improve performance.

Beta testers wanted

Because of these relatively major changes we would like some people to try it out before release. Please contact us via https://support.pscs.co.uk if you are interested in this. We will be testing it on our internal mail servers and test PCs first, but it is good to try it in different environments as well.


Comments (0)